Videos


How to downgrade PSP Official firmware 6.60 to 6.20 for all psp module



....READ THIS FIRST!!...

UPDATE!!!: Sorry for all users that get error when trying this downgrader!! I upload the old version of downgrader
Use this :
_______________________________________________________________
new downgrader fix!! 6.xx v4.1 : http://dl.qj.net/psp/homebrew-applications/6xx-downgrader-v4-1.html
_______________________________________________________________


Welcome to my Video Tutorial!!
In this video i will showing you guys on how to downgrade your PSP 1k,2k, 3k and GO without the pandora battery.


The new 6.xx downgrader v4 has been released by some1. The 6.xx downgrader v4 allow us to downgrade from Official firmware 6.60, 6.39, 6.38, 6.35 and 6.31 to any desired firmware that you like. I choose 6.20 because it is safe for me to use the PERMA PATCH or TN hen. Thanks to some1 for 6.xx downgrader.

Installation :
Please read carefully!!

New 6.xx downgrader v4.1 Here [09g suppoerted!!]:
http://dl.qj.net/psp/homebrew-applications/6xx-downgrader-v4-1.html

Download 6.xx downgrader V4 Here :
http://www.mediafire.com/?x2kbc1ekhfkr3xx

Download PSP module checker Here:
http://www.mediafire.com/?kbkbd5eljen7l7y

Copy the 6.xx downgrader and the Module checker and paste it to your PSP/GAME folder but, do not Copy the UPDATE yet. Run the Module checker first before you do anything. now check your Device Module. if your PSP module is lower than 07g, you need to use the 6.20 UPDATER. If your PSP module is upper than 07g, you need to use the 6.35 UPDATER. After you have pick up the UPDATER. Run the 6.xx downgrader. Press "X" buttons to start the SCE updater. now, if you see nothing happen and that mean's you have use the wrong UPDATER or Maybe you have used the PSP Go UPDATER.. Change it and Run the 6.xx downgrader once agains. Now, if it work it should bring you to the Installation program. Accept all agreement.. Now start the Installation.. Wait untill it finish.. After it finish install the Updater, Blue screen of death will appear. No need to worry by pressing the "O" buttons all come to normal.
Now go to setting and system setting and "WALLA". your PSP have been success downgrading.

Download UPDATER 6.20 here!
For those users that is lower than 07g, download this UPDATER

6.20 for Non-[PSPGO] :
http://www.mediafire.com/?3vxazm09pkrkblb

6.20 for only [PSP GO]:
http://www.mediafire.com/?2es2s1fzkd1b2b9

Here is updater for those who have up to 07g.
You need to update it to Official firmware 6.35.

6.35 for Non-[PSP Go ]:
http://psp.dashhacks.com/file/2036

6.35 for only [PSP GO]:
http://psp.dashhacks.com/file/2012

Notes:
I will take no responsibility if you BRICK your PSP. This Program have been successfully try by ME..

Don't forget to subscribe!! I really appreciated it.
Like my channel? add me as your friends!
Remember if you like to see this video, click the LIKED!
Comment me if you have problem with this tutorial!

Thanks you for watching!!!!


Views: 48098
Added:
Runtime: 16:48
Comments: 222

Tags for this video:



Find more videos in the: "24"
Uploaded by:
See more videos uploaded by


Comments:

Author Urashi Nagashi ( ago)
dead link

Author MOHAMMAD alqasem ( ago)
psp will never die just like ps2 :)

Author brock breacher ( ago)
mine is 09g so now what!!!!!!!!!!

Author jovan jerek tan ( ago)
place the downgrader and update folder of your corresponding g thing. run
the downgrader and it will automatically do the rest.

Author PicusTVtm ( ago)
i have fail if i start downgrader: the game could not be started.(80010002)

Author Valkemie ( ago)
YOU ARE SAVING MY TIME 

Author reyn castro ( ago)
the link can't work sir pls help

Author Khern Tze Kay ( ago)
Here is updater for those who have up to 07g. You need to update it to
Official firmware 6.35. 6.35 for Non-[PSP Go ]: psp.dashhackscom/file/2036
LINK DEAD!!!

Author Ralph3able ( ago)
SHIT!! The downgrader and the module checker became corrupted in my PSP
version 6.60

Author Ralph3able ( ago)
The module checker!!

Author ACME ( ago)
no offence but u need to learn to spell, amigo, and your grammar sucks,
sorry, good video still... Ur more of an i.t/math guy aren't u?

Author touchless777 ( ago)
Thanks alot!!!! Easy to follow...

Author Kirigaya Nash Moonslash ( ago)
The Downgrader gets Corrupted when i Install it . What should I Do ?

Author Kirigaya Nash Moonslash ( ago)
Links are Dead man . Update it .

Author J25-115 ( ago)
does it work for all modules on psp 3000

Author Dan Edward Libao ( ago)
6.35 for Non-[PSP Go] link for this is dead

Author Dan Edward Libao ( ago)
asd

Author Diogo Sousa ( ago)
PSP module check!

Author ladose1000 ( ago)
the link for 620 non psp go dosen't work PLEASE update them

Author ladose1000 ( ago)
the module checker link dosen't work

Author ladose1000 ( ago)
the links are dead dude update them!

Author Jerome Devera ( ago)
3:20

Author VincenzoPazienza ( ago)
does this work for psp e1000 (psp street)? Thanks!

Author ItsGmezPoy ( ago)
why do we need to upgrade/downgrade the ofw? is it like for example, to get
6.60 cfw you would require the 6.60 ofw?

Author Κακομοιρης Κακομοιρογλου ( ago)
i have psp 3004 slim&lite 6.60 can i downgrade to 6.20 without fuck my psp?

Author Arthur Conrado ( ago)
link broken...

Author Angeline Tan ( ago)
link updater 6.20 for Non-[PSPGO] Don't Working :(

Author Nicolas Munoz ( ago)
You don't put it anywhere. It is the source code in case you want to do
anything to it or want to see what makes it tick.

Author Kirigaya Nash Moonslash ( ago)
Why the hell would dashhacks show me the fucking file ??!?!?!?!

Author Shawn_Senpai ( ago)
where do you put the SRC file?

Author Cheun Phak ( ago)
your link dosen't work but i use other link so I would like to say thank
you very much you help me. Thank you very much !

Author Roman Cendejas ( ago)
"a Later version of the system software is already installed." Any ideas?
Got it to work for my pspgo using this. but witha different OFW, my .04g
module won't work though

Author Kevin Montecalvo ( ago)
bro, i downgrade my psp 6.60 to 6.35,.i encounter says "later version of
this psp is already installed" how can i downgrade it perfectly??my module
is 9g,,psp3000

Author Vaibhav Nijhawan ( ago)
ur media fire links donot work

Author LiquidMystery1 ( ago)
THNXXXXXXXXXXX it Worked

Author SuperGame4ever ( ago)
which file?

Author Wesson552 ( ago)
links dont work nooo !!! please help

Author Rairu Mashū ( ago)
"Jump to 3:20 to start the tutorial!!!" Now this is a FINE video, not some
bullshit uploaders downloading and doin shit before the tutorial, + 1 (y)

Author Muhammad Haikal ( ago)
why it corrupted?

Author Pedro Ferreira ( ago)
where did you downloaded it from?

Author SkillahOgre ( ago)
it works also with other official firmware update's

Author NathanDiGreat ( ago)
Thanks man you helped me out alot. 6.60 was giving me CFW problems every
time i tried to launch for some reason

Author sooraj ib ( ago)
Thanks man you really rocked the show!!!

Author GAMES ( ago)
THX THX THX GOD WHEN I TRY YOUR SHIT TELL ME A LATER VERSION OF THE
SOFTWARE IS ALREADY INSTALLED THERE IS NO NEED TO UPDATE I WAS LIKE FUCK
WHY THAT HAPPEND AND AFTER 20 MIN MY FRIEND CALL ME AND TELL DO NOT DO THIS
YOU NOT GONNA BE ABLE TO PLAY A GAME IF YOU DO OMG GOD SAVE MY PSP AND I
UNSUB AND DISLIKE

Author SUPERDEADLYKING ( ago)
thanks bro!

Author Johny Walker ( ago)
Show HIM THE LIKE BUTTON!!!!!

Author 993mario ( ago)
Your the best subbing !

Author Mahdi el-harake (237 years ago)
ive got psp 3g and when i go nto downgrader it says x to proceed i click it
it doesnt do anything (stays the same) and says 5 seconds to exit and axits
by itself. pleeeease help!!!

Author Chosen Kingz ( ago)
why does it say game could not be started

Author mrvideoman46 ( ago)
Gimme your theme...Its sick

Author MakusiowyPL ( ago)
After a downgrade Can i update to 6.39 ?

Author Chue Thao ( ago)
Game cannot be started! please help!

Author TheKrieg14 ( ago)
y on me me game could not be started? i got psp 9g mod. and 6.60 firm!help
pls!

Author blair ferguson ( ago)
it worked. im a total noob, and have been trying for days to make this damn
thing work, until i stumbled onto your video. thank you so much.

Author Captain America™ ( ago)
i can get picodrive and gpsp without saying corrupted file now right

Author Ben Reyes ( ago)
by the way i'm using 6.35

Author Ben Reyes ( ago)
I have a problem. When I try to run the updater it says "The update cannot
be started. The data is corrupted. (IDXFFFFFFFF).

Author SupaReVvo ( ago)
ME TOO!

Author Leonardo ( ago)
thanks, it really worked!!!

Author Kostas Filoksenis ( ago)
THANKSSSSS I GOT MANY PROBLEMS,UNTIL I WATCHED THE WHOLE VIDEO AGAIN,THANKS
THANKS!

Author ItsJstAPotHeadThing ( ago)
when i start the downgrader and it goes black and when it suppose to show
the update start menu says "a later version of the system software is
already installed. there is no need to update (CAAFFFFFCF7)

Author Ramon Moran ( ago)
thank you soo much

Author Lt Seth ( ago)
wtf? i cant play my iso games help here?

Author rocketlander3 ( ago)
Mine says "This game couldn't be started. (CAAFFFFFCF7)" How do I use the
UPDATER?

Author rocketlander3 ( ago)
ps i know now =3

Author rocketlander3 ( ago)
i dont know if my psp is go or not how do you know it?

Author songlover27fly ( ago)
can you help me to my problem ? i downloaded a 6.60 version and after i
installed it to my psp my psp can't read any game at all ?? can yiou help
me please ?

Author xLuWing ( ago)
my one is 03g ... so can use it??

Author Luca Brasi ( ago)
WHEN I COPY THE FILES INTO GAME FOLDER,AND ONCE I TRY GOING TO THE FILES ON
THE GAME MENU IT SAYS FILES ARE CORRUPTED. WHAT TO DO?

Author Orest Suylk ( ago)
It says "A later version of the system software is already installed. There
is no need to update. (CAAFFFFFCF7)"

Author Dp10ms ( ago)
bro just download the 6.60 updater and you have it again

Author 99kkan ( ago)
and when i put them in the psp there corrupted

Author 99kkan ( ago)
hi, the downgrader gives me a bunch of random files like SRC PSP and readme
pm me plz i need help!

Author Crimson Nyte ( ago)
whats the song? completely badass!

Author Zomb1e_V1rus ( ago)
Thank u so mush i was tring to do this for hours whith other things, thanks
agin

Author Ryuuichie ( ago)
one thing.. why the hell did you try a psp go updater ?! you mad bro ?!

Author Ryuuichie ( ago)
thanks. you just earned a potato :)

Author Neko Tyty ( ago)
hey I did everything the description said to do, but the downgrader did not
work. what did i do wrong?

Author mssiddharth2000 ( ago)
hey guys make sure you have plugged in your charger while downgrading.there
is a good chance for a brick..plz some one post a link to install 6.20 god
permanent for psp go.(only 6.20)

Author Dark Warrior ( ago)
do this work on the psp go?

Author TheBlaze000 ( ago)
would it work if i do the same thing with a PSP GO?

Author heart broken ( ago)
bro mine says game could not be started 80010002 help me plz bro am 6.60 ofw

Author ilikefinalfantasy ( ago)
It worked for my PSP 1000 version 6.60 > 6.35. When I did the same thing
with my PSPGO 5g version 6.60, I keep getting error 'the game could not be
started. (80010002). Any idea how to fix this please!

Author SuperGame4ever ( ago)
@0306eros You are welcome.

Author SuperGame4ever ( ago)
@awatkins249108 What firmware actually you use right now?

Author SuperGame4ever ( ago)
@awatkins249108 Don't update.

Author SuperGame4ever ( ago)
@Faraazjat Use 6.20 firmware.

Author megachromer ( ago)
holy shit it actually worked! thank you so much! liked and subbed! :D

Author Faraz Nmeh ( ago)
i have a psp go

Author Faraz Nmeh ( ago)
plz respond

Author Faraz Nmeh ( ago)
what do u do if it is 05g

Author Arun Marhatta ( ago)
It keeps on telling me when its about to install that the version is
firmware 6.60 and there is no reason to update.

Author Riptaliator ( ago)
OMG finally it worked! I owe you haha :D

Author 756RainyDays ( ago)
Thanks man the best like a boss!! >:D

Author CoolHardy14 ( ago)
Thank you tons!! It really worked :)

Author si ( ago)
what if my psp is module 9g?

Author FalconCreationZ ( ago)
can i get some help? I have a 04g psp 3000 with 6.60 and every time i go to
use the 6.20 updater it says, "There is a later version, no need to
update". please help asap. Thanks in advance!

Author SuperGame4ever ( ago)
@summi5635 Which one?

Author SuperGame4ever ( ago)
@TheMariobros101 Thank you.

Author SuperGame4ever ( ago)
@jaynopl Thx..

Embed Video:

URL 
Link 

Search Video

Top Videos

Top 100 >>>

Videos

Analyse website